1.877.833.1202

Creating FastFind Templates in FileHold

FastFind templates allow you to automate searches in FileHold software from third party applications such as an accounting or ERP system. The application must have been created with Microsoft WinForms based technology in order for this method to be effective. You create the templates for the third party application and assign “hot keys” or shortcut keys to search the various areas of the forms-based application. This allows users to quickly search FileHold and access information related to the file they are working on in the third party application.

It is possible to configure multiple search hot keys for a single screen and template. Each of these hot keys can get their search data from a different location on the screen. Each of these locations is called a "source". Before a search will be performed with the data at the source location the screen will be validated to ensure it is the correct one for the template. This validation is done using "rules" that are defined to uniquely identify the screen. For example on an invoice screen, sources can be set for the fields, Customer Name, Customer Number, Amount Owed, Date Billed and Due Date while the rules determine the areas like the header, body, footer and menu areas of the screen to search.

In order to create FastFind templates, you must be a Senior Library Administrator or System Administrator.

To create a FastFind template

  1. Open the third party application that you are creating the template for. In this example, a Microsoft Money invoice is used.

  2. Go to File > Preferences and Settings > FastFind Preferences and select the Enable FastFind check box. Click OK.

  3. Go to Tools > FastFind Templates.

  4. In the list of FastFind Templates window, click Add Template.

  5. The message “Activate the window you want the FastFind Template to be associated with and press Alt+N.” appears. Select the third party application and type Alt+N.

  6. A “snapshot” of the application will now appear in the FastFind Template window. If the incorrect window was invoked, click Select New Window and repeat step 5.

Creating a FastFind template in the document management software

  1. Enter a name and description for the FastFind template.

  2. Click Add Rules. A “rule” tells the system where to locate the “source” or search term. In the following example, the whole invoice was selected as the area for the rule. This means that the whole “rule” area that is selected (outlined in a blue rectangle) will be searched when a source hot key is invoked.

FastFind - select a Rule

  1. The Add Rule window opens. Select if the rule has a dynamic position, a fixed position, or a fixed position and size.
  • If you use dynamic position, the Match Text option must also be used. Enter the text in the Match Text field. Click OK.

In the following example, a fixed position is used since the Invoice template in Microsoft Money is a consistent, non-dynamic template.

FastFind - Add Rule

  1. To see what area is covered for the rule, select the rule from the Rules list. The area that the rule covers will appear in light green. In the example below, the whole invoice form is highlighted in green.

FastFind- view rule

  1. Continue to create as many rules as needed.
  • To edit a rule, click Edit Rules/Sources.
  • To remove a rule, click the red X next to the rule name.
  1. Click Add Source. The source is the field on the form that is going to be searched in FileHold. For example, on an invoice this can be a customer/client name or customer number, invoice number or amount.

  2. Select the source on the form. This area will be highlighted in blue. In the example below, the Customer field is selected as the source.

FastFind - select a source field

  1. In the Add Source window, enter the Name for the source.

  2. If the source needs to match a pattern, select the Match Pattern check box and enter the pattern in the field.

  3. Select if the source has a fixed position or a fixed position and size.

  4. Assign a shortcut key to the source. In the example below, it uses Alt+A as the shortcut key.

FastFind - add source window

  1. Click OK.

  2. To see the field assigned to the source, select the source from the list. The source is highlighted in red.

FastFind - source highlighted in red

  1. Continue to create as many sources as needed.
  • To edit a source, click Edit Rules/Sources.
  • To remove a source, click the red X next to the source name.

In the example below, the invoice date and total amount were added as sources.

FastFind - All sources

  1. Click Save to save the FastFind template.

  2. Go to File > Preferences and Settings > FastFind Preferences and select the check box next to the template name enable the FastFind template and click OK. You can also enable the “Update FastFind templates when I log in to FileHold” so any changes made to the FastFind templates will be updated on your local computer.

FastFind - enable template

  1. To test your template, go to the third party application and type the hot keys that were assigned to the sources. FileHold will open as the top most window with the search results shown.

In the example below, the shortcut key Alt+B was used to search on the invoice amount.

FastFind - Search results

  1. If the FileHold search was not invoked, ensure your shortcut keys do not conflict with the shortcut keys of the third party application. If they conflict, you can edit the template to change the shortcut key. See below for details on how to edit FastFind templates.

To edit a FastFind template

  1. Go to Tools > FastFind Templates.
  2. In the List of FastFind Templates window, click on the name of the template to be edited.
  3. Make modifications as needed.
  • Change the name or description.
  • Click Edit Rules/Sources to modify the areas and shortcut keys.
  • Click Add Rules or Add Sources to add additional rules and sources to the template.
  • To remove rules or sources, click the red X next to the name.
  1. To save the changes, click Save.

To delete a FastFind template

  1. Go to Tools > FastFind Templates and click the red X next to the template name.

To print a "Cheat Sheet” for the template shortcuts

  1. Go to File > Preferences and Settings > FastFind Preferences.
  2. Select a FastFind template and click on Shortcut Summary. This will open a list of all the shortcut keys that have been created for the FastFind templates.
  3. To print the list, click Print.